Author Topic: BUG : Output instruction not written in .src file  (Read 1529 times)

Wall-E

  • Robots in Architecture Members
  • Forum User
  • *
  • Posts: 189
    • View Profile
BUG : Output instruction not written in .src file
« on: August 17, 2016, 12:51:16 PM »
Hi !

I have updated my 2D cutting definition to integrate the I-O s of my plasma cutter.
Just to be sure that the output which triggers the plasma is "OFF" or "False" at the start of the program, I have added a command from the "Set digital" component at the very beginning of the command stack.

Sadly, this does not seem to register in the .src file (see attached).

Cheers

Johannes @ Robots in Architecture

  • Lead Developer
  • Administrator
  • Forum User
  • *****
  • Posts: 758
    • View Profile
    • Robots in Architecture
Re: BUG : Output instruction not written in .src file
« Reply #1 on: August 17, 2016, 05:27:34 PM »
Hello,

Thanks for letting me know, I'll look into that. In the meantime, you can use the Reset IO State option in the Code Generation settings! Or alternatively create a custom KRL pattern where you set your output at the beginning.

Best,
Johannes

joaocosta

  • Forum User
  • *
  • Posts: 1
    • View Profile
Re: BUG : Output instruction not written in .src file
« Reply #2 on: November 15, 2017, 05:09:12 PM »
Hello,

Has this issue been resolved?
I'm experiencing the same problem: digital outputs won't show up in the .src file.
Am I missing anything?

Thanks!

Johannes @ Robots in Architecture

  • Lead Developer
  • Administrator
  • Forum User
  • *****
  • Posts: 758
    • View Profile
    • Robots in Architecture
Re: BUG : Output instruction not written in .src file
« Reply #3 on: November 16, 2017, 09:27:17 AM »
Hello,

IOs start with a state of OFF, so an additional OFF will not register.
You can override this behaviour by using a Custom-KRL component instead with e.g.
$OUT[1]=TRUE

Best,
Johannes