Author Topic: KUKA|Prc not generating KRL code  (Read 337 times)

RalphieRaccoon

  • Forum User
  • *
  • Posts: 5
    • View Profile
KUKA|Prc not generating KRL code
« on: July 27, 2017, 02:37:14 PM »
I'm having trouble getting the KUKA|Prc Core block to output any KRL code (*.src file). I've tried changing the name, directory, clearing and recomputing the Grasshopper solver, exposing and hiding filename and save input, closing and reopening Rhino/Grasshopper, and clicking APPLY about a million times.

Sometimes it works and generates a file, but I never seem to find out why. I just keep trying random things until it works. It takes forever and is very frustrating.  >:(

I'm running KUKA|Prc 2016-03-31 (Trial version), on Grasshopper 0.9.0076, on Rhino 5.0 on Windows 7 64-bit.
« Last Edit: July 27, 2017, 02:45:40 PM by RalphieRaccoon »

Johannes @ Robots in Architecture

  • Lead Developer
  • Administrator
  • Forum User
  • *****
  • Posts: 556
    • View Profile
    • Robots in Architecture
Re: KUKA|Prc not generating KRL code
« Reply #1 on: July 27, 2017, 03:33:46 PM »
Hello,

By default it should be very straightforward: When any input (except things like the simulation slider, which has got no effect on the code) changes, it will generate a new file. If you want to control that manually, you can right-click the Core component and choose "Expose Filename and Save Input". Then you can set the filename via text, and control the saving with a Button input. This functionality may not be available in the Trial version (though I think it is).

Hope that helps you understand the saving process, if there are still issues please let me know.
Best,
Johannes

RalphieRaccoon

  • Forum User
  • *
  • Posts: 5
    • View Profile
Re: KUKA|Prc not generating KRL code
« Reply #2 on: July 27, 2017, 04:34:49 PM »
Hmm... could it be that I'm trying to generate a new file when no inputs have changed? I sometimes want to save the same KRL in a new location or under a new filename.

Does the button input force a new file to be generated whether the inputs have changed or not? And if not, is there any way to do so?

Johannes @ Robots in Architecture

  • Lead Developer
  • Administrator
  • Forum User
  • *****
  • Posts: 556
    • View Profile
    • Robots in Architecture
Re: KUKA|Prc not generating KRL code
« Reply #3 on: July 27, 2017, 05:11:09 PM »
Changing the output folder and/or filename and pressing "Apply" should generate a new file as it constitutes a change.
If nothing changes, toggling the button won't generate a new file - this would be detrimental to your harddrive etc., if e.g. moving the simulation slider would cause a file to be overwritten hundreds of times.

Best,
Johannes

RalphieRaccoon

  • Forum User
  • *
  • Posts: 5
    • View Profile
Re: KUKA|Prc not generating KRL code
« Reply #4 on: July 27, 2017, 05:35:01 PM »
Quote
Changing the output folder and/or filename and pressing "Apply" should generate a new file as it constitutes a change.

Yeah, this definitely doesn't work for me for some reason.

EDIT: It doesn't seem to update when the inputs are changed either. Currently the only thing that seems to work is closing and opening Rhino again.
« Last Edit: July 27, 2017, 05:43:52 PM by RalphieRaccoon »

Johannes @ Robots in Architecture

  • Lead Developer
  • Administrator
  • Forum User
  • *****
  • Posts: 556
    • View Profile
    • Robots in Architecture
Re: KUKA|Prc not generating KRL code
« Reply #5 on: July 27, 2017, 07:56:53 PM »
Hello,
Is it possible that you ticked the "Simulate Without KRL Generation" box in the settings? Most examples have it enabled, so you don't get any error messages when your PC has got different paths than where the file was created.
Otherwise, please send me the file that is causing issues, so that I can take a look. Either as an attachment, or via eMail!
Best,
Johannes

RalphieRaccoon

  • Forum User
  • *
  • Posts: 5
    • View Profile
Re: KUKA|Prc not generating KRL code
« Reply #6 on: July 28, 2017, 04:28:13 PM »
Hi Johannes,

Here's the .gh file. I've definitely got the "Simulate Without KRL Generation" box unchecked.

Thanks for your help.

Johannes @ Robots in Architecture

  • Lead Developer
  • Administrator
  • Forum User
  • *****
  • Posts: 556
    • View Profile
    • Robots in Architecture
Re: KUKA|Prc not generating KRL code
« Reply #7 on: July 28, 2017, 04:35:11 PM »
Hello,

I've tested all the inputs and it always refreshed, so it seems to be working. I checked it by opening the file in Notepad++. It will provide you with a message if the file is refreshed while you had it open. Maybe just the Windows "date changed" is causing issues?
I might have some more ideas, please keep me updated.

One last thing: You should use ReduceMesh to reduce the complexity of the tool, it slows Grasshopper down quite a lot.
Best,
Johannes

RalphieRaccoon

  • Forum User
  • *
  • Posts: 5
    • View Profile
Re: KUKA|Prc not generating KRL code
« Reply #8 on: August 02, 2017, 01:18:23 PM »
Okay, so it looks like it's something wrong with my install of KUKA|Prc, or windows itself. Guess I can try a reinstall.

Johannes @ Robots in Architecture

  • Lead Developer
  • Administrator
  • Forum User
  • *****
  • Posts: 556
    • View Profile
    • Robots in Architecture
Re: KUKA|Prc not generating KRL code
« Reply #9 on: August 02, 2017, 03:44:11 PM »
Hello,

Did you test it with Notepad++, is the *.src file refreshing?
If not, please send me your GH file, just so I can take a look at it.
You can maybe try starting Rhino with administrator privileges (via right-clicking the shortcut) to rule some more issues out.

I don't believe that it's an issue with your Windows, so re-installing everything probably won't change anything.

Best,
Johannes