Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - d2b Design

Pages: [1]
1
General Discussion / Spindle to DeviceNet Connection Guide
« on: July 24, 2019, 11:53:41 PM »
Hi all,

We're preparing to connect a 9kW spindle to our KUKA KR250 for wood milling and we're wondering if anyone is using DeviceNet to control parameters on a VFD or initiate a tool change, etc. I saw a previous post about configuring Beckhoff modules through Work Visual, but nothing on DeviceNet.

In general I'd like to create a guide for setting up a spindle for milling with the KUKA - it seems like something everyone is interested in!

- Dante

2
General Discussion / Re: BCO Motion Error (1058)
« on: April 17, 2018, 12:57:04 AM »
Problem solved! We cold booted the machine by going to Configure> Special Functions > On/Off Options > Force Cold Startup. For reference, we're running a KRC2 controller with a KRC1 pendant (it sounds like the options might be a little different on the later versions of the pendant).  The KUKA tech told me that some machines have a hibernation function, so they save certain states during a reboot...I'm not sure why the BIOS reset didn't erase the saved states, but we're up and running now!


3
General Discussion / BCO Motion Error (1058)
« on: April 14, 2018, 06:21:54 AM »
Hi everyone,

I just ran into a 1058 Error "BCO Motion: Press Start Plus" and am having difficulty getting our KUKA to run a program again. I successfully ran programs earlier today, and only got the error after running part of a program in reverse.

So far I've:
- checked the robot speed (set to 100%)
- edited backwards.ini, set Implicit BCO = TRUE, and later changed back to FALSE (per the error manual)
- cancelled & reset the program
- rebooted the controller
- reset the BIOS
- remastered the robot

But the error is still there...  :o

Any suggestions would be great!

I'm running a KR250 with a KRC2 controller.

- Dante

4
Support / Re: Error 2138 "name invalid for this type of constant"
« on: February 26, 2018, 09:25:47 PM »
Thanks, problem solved!

5
Support / Error 2138 "name invalid for this type of constant"
« on: February 26, 2018, 07:52:50 PM »
Hi everyone,

I'm trying to run a simple PTP command to test our robot's functionality, and I'm getting a 2138 error when compiling the code on the KCP that states "Name invalid for this type of constant". The error occurs on line 16: BAS(#PTP_PARAMS,45)

I attached the .src file, the Grasshopper file, and the bas and $config files that are located in our R1 > System folder.

I'm running a KR200-2 (from a GM factory) with a KRC2 controller, and a v1 pendant, with KSS v4.1.6.

Any help is greatly appreciated!

- Dante

6
Support / Re: KRC2 Cross3 start up program unable to start
« on: February 26, 2018, 07:18:44 PM »
Hi jschmidt,

We had a the same issue with our KRC2 controller, and were able to fix it by changing the date in the Windows OS. Go to Windows > Control Panel > Date and Time and see if the date seems strange (ours was set to 2099). We also deleted the .freeze file in our krc:/bin folder, as suggested by this post:
https://www.robot-forum.com/robotforum/kuka-robot-forum/boot-stops-in-kuka-cross/

We think we got the error due to low battery voltage. To check this, make sure the KCP stays on while the controller shuts down.

Good luck!

- Dante

Pages: [1]