Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - singline

Pages: 1 ... 3 4 [5]
61
Tutorials / Video Tutorial - Drawing & Engraving
« on: January 15, 2017, 04:16:40 PM »
Hey Guys,

I've started a series of video tutorials for KUKA PRC and Grasshopper. First one is live now and hot wire cutting is coming up soon!

bit.ly/KUKA_Drawing

62
Support / Tool Offset
« on: September 04, 2016, 06:38:26 AM »
I'm working on a vertical plane in the cell - the tool offset is moving in the z-axis, is there a quick way yo switch to x or y?

- sorted. just had to orientated my planes instead of being lazy.

63
Support / Re: Tool Path Axis for Hot Wire
« on: September 01, 2016, 01:43:40 PM »
yep - all sorted. thank johannes.

64
Support / Re: Tool Path Axis for Hot Wire
« on: August 31, 2016, 07:36:07 PM »
I've put this together. One issue is that with all the cuts currently being merged on axis is rotating too much going between the starts of new cut lines.

I'm thinking if I put in a PTP move from the end of one to the start of another it will stop some of the interpolation?

Or is there a way I can insert a line to unwind the axis before moving onto the next stage in the code. Currently it cuts all sides, then top slice and bottom. Its currently hitting the red line when it moves from sides to the top.

Maybe I can send it back to the start to unravel and then re-enter the process?

65
Support / Re: Tool Path Axis for Hot Wire
« on: August 18, 2016, 04:28:46 AM »
Hi Guys,

I'm having a hell of a time generating paths from a brep form to subract from a syrofoam block. Have to ensure the kuka isn't attempting to pass through the material and performing sweeping motions in the correct direction to basically subtract chunks of styrofoam to be left with the original brep shape. I've attached an image i am hoping communicates what I'm trying to produce.

I've been trying to set it up parametrically so i can put in different forms and cut without having to adjust the GH too much.

Any and all help would be greatly appreciated..

66
Support / Extruder for KUKA
« on: August 12, 2016, 01:39:32 PM »
Hi Guys,

I'm wondering if anyone has any experience with making an end effector for 3D printing/extruding on the end of a KUKA. I'm starting at 0 on this one and was hoping for a little leg up to get me started on the actual design and fabrication of the end effector and controlling the plastic flow?

I'm taking inspiration from the works of Fabio Gramazio & Mattias Kohler's work at ETH Zurich, 2013.

Regards,
Karl

67
Support / Open Close Air
« on: August 03, 2016, 02:11:27 PM »
Hi,

This one is a little more KRL than PRC. I have a lovely pick and place setup in PRC based on the tutorial file. That works with manual air, but I'm attempting to use the code that the spindle uses when picking up a tool - in my mind this should work - to turn on and off our KUKA's air.

Code: [Select]
OpenCollet
GLOBAL DEF OpenCollet()

    ; Stop the spindle if it is running
    Spindle(0)
    WaitForAir()

    ; Open the collet
    doRobCellSpindRel = TRUE

    WaitForColletOpen()

END
;ENDFOLD

;FOLD CloseCollet
GLOBAL DEF CloseCollet(WaitForTool : IN)

    DECL BOOL WaitForTool, WaitForToolD

    WaitForToolD = TRUE
    ON_ERROR_PROCEED
    WaitForToolD = WaitForTool

    ; Stop the spindle if it is running
    Spindle(0)
    ;WaitForAir()
    ; Close the collet
    doRobCellSpindRel = FALSE

    IF WaitForToolD THEN
        WaitForColletClosed()
    ENDIF

END
;ENDFOLD

This is not working - so I attempted to frankenstein the code which just threw up more errors.. any one have an ideas?

In my KUKA|PRC I have the custom KRL command ready - I just can't figure out the command I need?

I hope this is somewhat clear.

68
Support / Re: Tool Path Axis for Hot Wire
« on: July 27, 2016, 11:20:35 PM »
Thanks for the prompt reply Johannes. I understand that - but in my head i had it running correctly in one direction with no full twist of A6 - when I reversed the command line why does it then have to 'untwist', wouldn't it run the exact same points, just in the reverse motion? At the end of the path, when the kuka returned to the end position, it untwists A6 which wasn't twisted in the non-reversed version? Does that make sense?

69
Support / Re: Tool Path Axis for Hot Wire
« on: July 27, 2016, 02:59:43 PM »
Its seems to be going ok, but I just can't figure out why the KUKA does what it does when I attempt edit my path.. If I try to reverse the order it gives me an error on axis 6 and also if I repeat the first list item at the end to ensure a full circle I have the same issue.

It runs fine up until I'm adding in the new list item. It runs around but doesn't complete a full rotation of the styrofoam. And I wish to reverse the motion due to tension on a couple cables..  ???

70
Support / Re: Tool Path Axis for Hot Wire
« on: July 22, 2016, 05:01:52 AM »
I believe I have found the core issue  - the origin of the movement was not placed correctly for the tool, which then needed another adjustment.

Johannes, thank you very much for the prompt and helpful response, if we ever have the chance to meet I owe you a few beers.

71
Support / Re: Tool Path Axis for Hot Wire
« on: July 22, 2016, 02:11:31 AM »
I resorted to rotating each of the 10 planes individually so that x axis is directed outwards - but the robot still goes through the model ... when i use the rotated planes the robots tool still doesn't go to the x axis..

72
Support / Tool Path Axis for Hot Wire
« on: July 21, 2016, 03:17:20 PM »
Hi,

I'm hoping someone can help me - I'm attempting to do circular hot wire cutting. I have everything working apart from that I require the x-axis to always be perpendicular to the cut lines to ensure my tool doesn't pass through the styrofoam. Everything I've tried so far has shifted the Z axis.. ?

I've attached the 3dm and gh.

Thanks.

73
Support / Re: Custom tool axis issue
« on: May 21, 2016, 09:01:59 AM »
the way I see it, if I'm going devote months of my time getting it all working smoothly, it may as well be funny!

I can assure you since figuring this out, I am now head deep into advanced pick & place with emergence algorithms via GH + KUKA prc.. thanks again for your assistance, couldn't have done it without it.

74
Support / Re: Custom tool axis issue
« on: May 18, 2016, 10:16:21 AM »
Yes, that was exactly the issue, thank you for the prompt reply!


75
Support / Custom tool axis issue
« on: May 12, 2016, 11:03:06 AM »
So I've setup a very simple custom tool to hold a chalk pen - photo attached.

The simulation runs all correct based on the 'drawing and engraving' sample provided, but for some reason when exported to the KUKA the robot is going through the table instead of coming down on the z-axis as shown in the simulation?

In the simulation if I set the custom tool Tool B rotation to -90 the simulation is correct but it doesn't seem to correct at the KUKA end?

Any ideas what I'm missing?

Pages: 1 ... 3 4 [5]