<SYS-X44> Error during ECat stack initialization [NetworkResponse() iiwa

Started by DIA_Sina Mostafavi, October 28, 2021, 07:26:56 PM

Previous topic - Next topic

DIA_Sina Mostafavi

Hi Kuka-gurus,

We are trying to initiate our KUKA lbr iiwa 14 R820 on a flexFELLOW 900 standard, and we cannot troubleshoot the following base error for I/O on the smart pad:

<SYS-X44> Error during ECat stack initialization [NetworkResponse() no Network Response]—> Error of Field Buses (FlexFellow)

Fixing the issue with I/O mapping in WorkVisual does not work, because the software does not recognize the created IOConfigartion.wvs file.

Does anyone have a clue!
Attached are further details and snapshots.

PS: We are using WorkVisual 5.0.5 Build0600 for Sunrise.OS 1.17, which is compatible according to the KUKA support line and release notes.

Johannes @ Robots in Architecture


So to first state the obvious, the robot cannot find periphery connected via EtherCAT. The first steps are usually to make sure that the EtherCAT coupler is connected to power, maybe the 24V supply for the Beckhoff got disconnected during transport?
If everything is physically correct and powered, I would just create a new project in Sunrise and then edit the WoV file accordingly, with the Beckhoff elements in the right order, the same as in the WoV file that you can open in WoV 6. Then create the Sunrise IO groups and have it generate the Java code to access it.

Hope that helps a bit!

DIA_Sina Mostafavi

Dear Johannes,

Thanks for your prompt reply!

1. About the EtherCAT connection: we think that it is connected because out of 4 little green LEDs: 3 are on and only one of them is off (we assume the one for the IO, Attached is the photo).

2. About "I would just create a new project in Sunrise and then edit the WoV file accordingly": We did this and also create a new workspace with a new project in Sunrise but still WoV is unable to open the file!

3. We also tried to create a new IOConfiguration file project in WoV and it does not create a new file project at all! Therefore, we are unable to recreate IO setting accordingly to the information we get when we open it in WoV 6.

4. If we get the information of the IOConfiguaration.wvs file it says it is created with a different WoV file V5.0.2 Build0313. We also tried to open that file in the corresponding version but still, we get the same error. We are not sure if this is one of the reasons that we cannot get the IO setting right.

Many thanks again for the wonderful support.

Sina Mostafavi & Benjamin Kemper

DIA_Sina Mostafavi

Hello again,

we have the following updates:

1. related to the software issue with WoV 5.0.5.: Its seems, that the specific laptop (windows 10) has a problem to run WoV correctly. We've installed a virtual machine running Win7, and both programs run correctly. The IOConfiguration.vws can be opened and I/Os can be mapped. For now it works, but obviously not the finest solution.

2. The SYS X44 error stays after synchronization. The field buses of the FlexFellow platform still produce the error. The pre-wired Beckhoff EtherCAT bus looks correctly wired, however on the attached nodes (A1: EL9188, A2: EL9189, A3: EL1809, A4: EL2809) seem to show no response. Also, the ethernet cable coming from X65 from the cabinet has no signal light on the socket of the EtherCat.

Do you know what to do? Thanks!

Johannes @ Robots in Architecture

Hello Sina,

The EtherCAT bus is usually running if all four LEDs of the EK1100 buscoupler are on (but may be blinking). If you look at the Beckhoff documentation, the fourth LED signifies "RUN": https://download.beckhoff.com/download/document/io/ethercat-terminals/ek110x_ek15xxen.pdf
Is the order of the Beckhoff modules correct? If they are in the wrong order, that also causes problems.
Finally, it seems to me that both the "In" and "Out" port on the EK1100 is used.
Is there any EtherCAT hardware configured in your WoV file except the one EK1100 with its modules?
If not, disconnect the EtherCAT cable going somewhere else, if you don't have any configuration for that "somewhere else". Could of course just lead to an external port that is empty!


DIA_Sina Mostafavi

Hello robotsinarchitecture community,

We solved the issue explained in the previous posts.

1. The external Beckhoff EtherCat field bus was not running because the internal coupler in the Kuka Cabinet was not powered. It needs to get powered via two bridges on the X55. The wiring you can find in the manual.
2. After that, in WorkVisual all used field buses need to be defined. If one is missing, you need to import the specific DTM file (can be found f.i. on the Beckhoff website)
3. The new order of field busses needs to be defined via WorkVisual. Under topology the order needs to be the same as the hardware.
4. The issue that the designated WorkVisual is not opening is bypassed for now with using a virtual machine and running Win 7.


Sina Mostafavi & Benjamin Kemper

Johannes @ Robots in Architecture