Turntable settings

Started by RoblabTUKE, November 25, 2021, 11:42:52 AM

Previous topic - Next topic


Hello friends!

Like many of you, I struggled with turntable calibration + KRC4 settings.

I came across a few mistakes in the procedure from the Mr. Petr Vacek / pozdravujem do čiech ;) /

Robot - KRC

1. Calibrate any tool, that has sharp TCP. Use standard 4-point calibration method. Save the calibration under any available number (mine is #7).

2. Calibrate External Kinematics Root Point. Follow instructions and use previously calibrated tool. Calibration mark of turntable is a little cross engraved into it's flange. You get XYZ ABC coordinates of  turntable table root point.

3. Set table to original position (no tilt) of any axis.

4. Calibrate Offset Base of External Kinematics.  Use previously calibrated tool (mine is #7). Save the base under any available number (mine is #6).

4A.  Follow instructions: First you have to place TCP to the origin of new base, which is the center of turntable flange (I used paper tape to fill the hole and mark center point exactly). Then move TCP to any point in X direction (in my case it was calibration mark). And finally move TCP to any point in Y direction (I marked perpendicular line onto turntable flange). Write down values XYZ ABC.

5. Set up a definition with turntable component and right click it to set values. Use XYZ ABC values "Root Point" from step 2.  Apply values.

6. Open Robot Core component to set robot base values. Use "offset base" values from step 4.

Use XYZ ABC values from "offset base". Apply values. Set proper base number, which in my case is #6.

Second problem was the KRC4 setting:

We have in LAB KUKA KP1-V single-axis positioner

Native setting ET1_TA1KR was  /X,Y,Z,A,B,C/  0,0,0,0,0,90

C = 90 is stupidity from KUKA

Changed setting ET1_TA1KR was  X,Y,Z,A,B,C = 0,0,0,0,0,0  / Image1.jpg /

C = 0

Third problem was the wrong orientation of rotation

Native setting $AXIS_DIR[7] variable was 1

Changed setting $AXIS_DIR[7] variable was -1

I'm stuck here.

This cannot be changed by overwriting values in machine.dat !

But the solution is simple:  Transmission ratio RAT_MOT_AX change from -2993/24 to 2994/24 and deploy  / Image2.jpg /

Test: https://www.instagram.com/p/CWsnkPSDDbD/

Johannes @ Robots in Architecture


Your post is missing a question!



PRC - has the default setting - that E1 is a linear axis and E2 is turntable.

I had it set up the other way around in KRC4.

Rewriting the code is crazy.

The solution is reversing the axis order in WorkVisual / Image 4, 5 /

Detail: Component - DKP400 contains  - switch E1/E2 - but component  - CustomTT does not contain it

Also, if you want to have infinite rotation, change the value: Rotatory to Endless

Johannes @ Robots in Architecture


The order of the external axes should depend on the order they are connected in Grasshopper, at least it should.



Hi Johannes, I didn't know that - I'll try it too. Thanks


Its not working - the order of E1 and E2 has not changed, it even changed the values :o :-X

Johannes @ Robots in Architecture


I just tested it, the result is funny and definitely not intended.
I've put it onto my to do list!

Thanks for pointing it out!