BCO Motion Error (1058)

Started by d2b Design, April 14, 2018, 06:21:54 AM

Previous topic - Next topic

d2b Design

Hi everyone,

I just ran into a 1058 Error "BCO Motion: Press Start Plus" and am having difficulty getting our KUKA to run a program again. I successfully ran programs earlier today, and only got the error after running part of a program in reverse.

So far I've:
- checked the robot speed (set to 100%)
- edited backwards.ini, set Implicit BCO = TRUE, and later changed back to FALSE (per the error manual)
- cancelled & reset the program
- rebooted the controller
- reset the BIOS
- remastered the robot

But the error is still there...  :o

Any suggestions would be great!

I'm running a KR250 with a KRC2 controller.

- Dante

Johannes @ Robots in Architecture

Hmm... I never had that problem, so I'm just making guesses: You might want to check if a button is stuck. That hasn't happened to me ever, but as you tried everything else I would have recommended (the "official" troubleshooting and rebooting, not sure if it's a good idea to reset the BIOS for every error) I'd push the Start plus and minus buttons a few more times with a bit more force, just in case. Also the green button on the back!
Then change into a higher user group and activate the Start-Up mode (where it overrides the X11 safety, but only allows T1), just to see if it changes anything when you run a program.
Finally, go into the safety settings, change something and then change it back, as BCO is a safety-relevant feature maybe it helps.
Last idea: Select a program and then do block selection on an axis movement - could be just the first axis movement, or another one further down.

If that doesn't help, get in touch with the KUKA hotline, they are usually really quick with those obscure problems.
Please let us know what helped!


d2b Design

Problem solved! We cold booted the machine by going to Configure> Special Functions > On/Off Options > Force Cold Startup. For reference, we're running a KRC2 controller with a KRC1 pendant (it sounds like the options might be a little different on the later versions of the pendant).  The KUKA tech told me that some machines have a hibernation function, so they save certain states during a reboot...I'm not sure why the BIOS reset didn't erase the saved states, but we're up and running now!

Johannes @ Robots in Architecture

That's great, thanks for sharing the solution! Hibernate saves the current data on the hard drive, so a BIOS reset wouldn't delete it. I've disabled hibernate on all my robots so that they cold-boot all the time.