Error during ECat stack initialization?

Started by shelbydoyle, June 08, 2019, 12:14:32 AM

Previous topic - Next topic


KSS13012 "<SYS-X44> Error during ECat stack initialization [NetworkResponse () no Network Response]"
(Nothing is plugged into X65 (EtherCAT)

It seems to be otherwise working... can I ignore this error or does it need to be fixed?

Johannes @ Robots in Architecture


Hmm... I think with an EtherCAT error you can move the robot in T1 but not in AUT.
Can you check if there is an EK1100 inside the controller, and if so if the lights are on when the controller is running? If not, you need to make the 2-cable bridge I mentioned in the other post to provide it with power.
Or if the robot was used by someone else before, then there might be a difference between the configuration and the actual robot. Load the current WorkVisual project from the controller and check if something shows up on the X44 that is not there in reality.



Hi Johannes,

We thought we had the eCat error fixed once we successfully jumped the X55 connector. The message away and were able to run automatic programs for a few days. It was working great.

The problem returned when I started configuring the controllers for Roboteam. I did two things on both controllers. Not sure what caused the error, but now they both have it again:

1.)   I renamed both controllers from the pendant Start-Up wizard to KUKA1 and KUKA2. Previously, they were named after the controller serial number. We are eventually going to have students working and I wanted to make the machine ID more clear.
2.)   I connected the controllers to an ethernet switch via CAT5 on the X65 (KLI) connection.

As prompted, I saved the changes to the RDC and then performed a controller restart with the file refresh / update option checked. After reboot, the SYS-X44 error came up. Once again, we can't run programs in AUT.


I tried the following to attempt to fix the issue. None of these worked:

1.)   Checked the X55 connections; both seated correctly. Same error with them plugged in or not. (hardware likely not the cause as it affected both systems after the software change)
2.)   I unplugged the X65 connections and renamed the controllers back to their original names and reset, etc. (tried to return it to the earlier state)
3.)   I changed the X44 restart value in KRC\Roboter\Config\User\Common\ECAT_SYS_X44.xml from "manual" to "auto", restarted etc.
4.)   I opened the current project in WorkVisual, removed the X44 interface and re-added it. eCat came attached to it by default. I deployed the project and restarted the controller.

I'm not certain whether I need to fix something else in WorkVisual, like you said. Perhaps we aren't properly running the shutdown sequence to recompile / deploy the files?

Do you have any ideas for things we could try?


Johannes @ Robots in Architecture

Hello Nick,

I'd start by activating the old project again, that previously worked - just to make sure that the problem is software and not hardware related.
Then do the changes step-by-step, first the controller name, then the RoboTeam etc.
Also, verify that any connected EtherCAT periphery (EK1100 etc.) is correctly powered with the LEDs on.
As you connected the robots via Ethernet, did you make sure that they do not use the same IP address? I don't think that would have an impact on EtherCAT, but who knows...

Finally, a cold-boot from the Shutdown menu, with re-load files ticked, is never a bad idea.


Johannes @ Robots in Architecture

I just checked, are you SURE that the X65 port is the KLI port?
On the Agilus - if I remember correctly - it's the EtherCAT port, which would explain your EtherCAT problems. X66 on the side would be KLI.



I'll try all of that today. Thanks for getting back to us.

((Sorry meant the X66 port as the KLI port! We aren't plugging anything into EtherCAT at the moment.))