Author Topic: how to setup MXA module in PRC  (Read 625 times)

pyw110001

  • Robots in Architecture Members
  • Forum User
  • *
  • Posts: 2
    • View Profile
how to setup MXA module in PRC
« on: July 09, 2020, 03:57:44 AM »
hi,everyone, i'm having trouble with the setup.
The current situation is that i've installed MAX(3.0x,My KSS is 8.5) on the robot and the UPD_Server Example has been successfully run,but it didn't work in PRC.
I've disabled the firewall on the PC. I'm not sure if there is a problem with the MXA settings, can someone help me, do i need to set up Physical IP on Mxa Module,is that my PC IP address or somethingelse, and where can i get the Robot ID?

Johannes @ Robots in Architecture

  • Lead Developer
  • Administrator
  • Forum User
  • *****
  • Posts: 1068
    • View Profile
    • Robots in Architecture
Re: how to setup MXA module in PRC
« Reply #1 on: July 09, 2020, 11:17:35 AM »
Hello,

If you got the KUKA software to work, most of the work is done.
The problem is most likely related to the mxA version - KUKA|prc should present you with an error number if it doesn't work, which you can look up in the manual.
If you let me know the exact version number of your mxA, I can send you a specific build that uses your version of the library.
The physical IP only applies when you are running mxA on a virtual robot controller. Unless you are using multiple robots, leave the ID at 1.

Best,
Johannes

pyw110001

  • Robots in Architecture Members
  • Forum User
  • *
  • Posts: 2
    • View Profile
Re: how to setup MXA module in PRC
« Reply #2 on: July 10, 2020, 08:38:24 AM »
Dear Johannes,
thx for the reply. the KSS is 8.5.7 HF and MXA v3.0.3. I've tried many times but still can't get it to work. :'(
The error code is shown in the figure. In order to successfully run the DEMO program I set the $MOVE_ENABLE port to 2060, does that matter ?
Do I need to open any programs when under EXT mode?

Johannes @ Robots in Architecture

  • Lead Developer
  • Administrator
  • Forum User
  • *****
  • Posts: 1068
    • View Profile
    • Robots in Architecture
Re: how to setup MXA module in PRC
« Reply #3 on: July 12, 2020, 10:12:19 PM »
Hello,

If you look at the error code that should be shown in the mxA component, then 99.9% it's the wrong mxA version.
You don't need to open a program, and $MOVE_ENABLE needs to be at 2060 (rather than the 1025 you use for jogging).
I will send you a link to the version for 3.0.3 in the next few minutes!

Best,
Johannes