Author Topic: KRC2 KCP connection error watchdog error  (Read 241 times)

rotax

  • Forum User
  • *
  • Posts: 1
    • View Profile
KRC2 KCP connection error watchdog error
« on: December 29, 2018, 01:34:15 AM »
Hey everyone, I am having some issues with my KRC2 and was hoping to pick your brain.

In a nutshell, I am working with a KRC2 ed05 running KSS 5.5.14 (the mode key is on the cabinet). The robot (KR500) and its controller were removed from the system it was integrated to. The buttons no longer work on the KCP (the estop and display still work).

The KRC and KPC turn on and boot up. However, the controller has one error:
• 328: KCP connection error WATCHDOG_ERROR.

I am using an X11 jumper that I made.

These were the things that were unplugged:
1. DeviceNet was unplugged from the MFC card on the KPC.
2. X16 was unplugged.
3. C1.1 (X7.1 labelled in the cabinet) was unplugged
4. X13 was removed but I believe it was just the hole for the DeviceNet cable to go through.

X20, X7, X19, and X21 remain.

The systems that the above plugged into no longer exist.

I've tested the wire connections from the pedant itself to the X19 connector and there were not problems with it.

I am not sure what watchdog is or why the KCP is not connecting correctly. I am wondering if this is a hardware issue or remnants in the software of the previous system it was integrated into.

To check if it is a software issue, how can I reset KSS to factory defaults without losing the specific arm data? I've tried running the setup executable from the D drive, and leaving just the mada folder checked on the menu; however, all the configured IOs and etc are still in KSS after reboot. Is there a way to reset everything completely as if it came from the factory?

Is there a hardware place I should look at? Does X16 need a safety loop? Like X11 needed? Could it be an issue with my X11 jumper? Could it be an issue with RDC?

Any advice would be much appreciated. I can provide further information if needed.

Thank you in advance,
Matthew

Johannes @ Robots in Architecture

  • Lead Developer
  • Administrator
  • Forum User
  • *****
  • Posts: 822
    • View Profile
    • Robots in Architecture
Re: KRC2 KCP connection error watchdog error
« Reply #1 on: December 29, 2018, 09:40:30 PM »
Hello,

I've looked at some German search results with your error message (which is useful with KUKA robots) and they suggest that the KCP cable may be at fault.
So if you've got a second KCP or can borrow it somewhere that may be worth a try.
I usually get a full HDD image once the robot is working so that it's easy to restore. Otherwise if you've got the installation medium go with that. If not get in touch with KUKA, ideally they can provide you with a new installation medium!

Hope that helps a bit!
Best,
Johannes